Redes Brasil

Script para VERIFICAR LATÊNCIA e Envio de E-MAIL no MikroTik RouterOS !!!

Nesse vídeo você irá aprender como usar um SCRIPT que irá:

 

1 - Calcular a latência média para um determinado IP;
2 - Caso essa latência média ultrapasse um valor especificado o SCRIPT  poderá executar uma ou mais ações;
3 - Ou seja, poderá gerar logs,enviar e-mail, desabilitar uma rota e etc...

 

Faça download aqui do SCRIPT que calcula a média da latência.

Faça download aqui do SCRIP para envio de e-mail pelo GMAIL.


21 de junho de 2016

8 responses on "Script para VERIFICAR LATÊNCIA e Envio de E-MAIL no MikroTik RouterOS !!!"

  1. Ola. gostei muito do Script para VERIFICAR LATÊNCIA e Envio de E-MAIL. gostaria de saber se tem possibilidade dentro deste Script criar mais uma linha de comando que determine por qual link ou ether ele deva pingar. Tenho um balance com 3 links e queria monitorar cada um separado pelo ping de forma quando um não responder o ping ele ative outro script que ira efetuar determinadas tarefas... Se for possível por favor manda o código. as demais alterações necessárias ja vi como mudar. so preciso que ele ping não na rede geral mais pro ip 1.1.1.1 por uma determinada ether.

    • Olá Flavio, tudo bem? Sim, é possível. Você pode criar uma nova tabela de rotas, dentro dessa nova tabela você configura uma rota default pelo link que você quer testar e quando for dar um ping é só usar a routing-table que você criou. Por exemplo:

      /ping 1.1.1.1 routing-table=link1

      Grande abraço!

  2. Olá, tudo certo? Sei que o vídeo é antigo, mas é o mais explicativo que encontrei. Estou com um problema com o procedimento: "AÇOES TOMADA SE HOST ESTIVER FORA DE ALCANCE"
    Quando o host está fora de alcance, a tarefa continua sendo executada. Ele muda para o Link 2, depois do tempo estipulado no agendador de tarefa, ele volta para o Host 1. Ou seja, o link 2 fica ativo somente enquanto está no tempo de espera. Pois automaticamente ele troca para o link primário (que está caído).
    Como posso resolver essa situação? Muito obrigado.

  3. Bom dia sei que não são mesmo assunto porém quero fazer o seguinte to usando o :foreach para localizar se existe um queue simple com um determinado nome eu queria mudar para um :if mas já tentei vários e não foi.
    segue o script:
    :foreach i in=[/queue simple find where name="grupo-$grupo-$Plano"] do={
    :set criaGrupo 0;
    }
    :if ($criaGrupo = "1") do={
    /queue simple add limit-at="$rLimit" max-limit="$rLimit" name="grupo-$grupo-$Plano" priority=1/1 target=172.16.0.0/22 parent="$linkPrincipal" comment="GRUPO $grupo $Plano"
    }

  4. Boa noite, Thales! Primeiramente, muito obrigado pelo material disponibilizado gratuitamente, me ajudou bastante. Sem querer abusar, já abusando, vc vê a possibilidade de uma adaptação do seu script para o seguinte cenário? Uma matriz com 2 links de internet e uma filial também com 2 links de internet. O objetivo é fazer o monitoramento do ping a partir dos 2 links da filial até os 2 links da matriz (4 pings no total) e criar/atualizar as rotas sempre entre as duas possibilidades de conexão que entregarem a menor latência, garantindo assim que matriz e filial sempre estejam conectadas entre si com redundância e a melhor qualidade possível. Consegui avançar pingando simultaneamente o mesmo IP público da matriz a partir dos 2 links da filial sem precisar alterar a o gateway padrão, utilizando mark routing, mas não tenho conhecimento suficiente para fazer o script de forma a atender minha necessidade. Caso considere a ideia viável e tenha interesse em ajudar, favor fazer contato por e-mail para combinarmos (obviamente, estou disposto a contratar sua consultoria). Obrigado!

    • Olá André, tudo bem? Agradeço profundamente o seu feedback. Nós temos um script de failover e loadbalance disponibilizado no curso EAD de failover e loadbalance aqui no site. Com esse script e mais alguns ajustes no script de verificar latência acredito que você vai conseguir chegar a solução específica que você procura! Não é necessário ter conhecimentos profundos sobre o assunto, analisando o funcionamento desses dois scripts você vai conseguir criar a solução perfeita para o seu cenário. Qualquer dúvida não hesite em entrar em contato, grande abraço!

Deixe sua mensagem

VALIDAR CERTIFICADO

Redes Brasil - Central de Atendimento: (64) 3416-2345
WhatsApp chat